VS:NurbsSetPt3D

From Vectorworks Developer
Revision as of 14:35, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the coordinates of a point in the referenced NURBS curve or surface.

The index is zero based (0 to number of points - 1).

For a nurbs curve, index1 is the piece number of the nurbs curve. Index2 is the vertex number within that piece. NurbsCurveGetNumPieces will give you the number of pieces inside of the nurbs curve (1-based). NurbsGetNumPts will give you the number of points inside of a piece.

PROCEDURE NurbsSetPt3D(
objectHd :HANDLE;
index1 :LONGINT;
index2 :LONGINT;
pX,pY,pZ :REAL);
def vs.NurbsSetPt3D(objectHd, index1, index2, p):
    return None

Parameters

objectHd HANDLE Handle to NURBS curve or surface.
index1 LONGINT Index of point in NURBS curve, or u-coordinate of point location in NURBS surface.
index2 LONGINT V-coordinate of point location in NURBS surface.
p REAL New coordinates for the point.

Remarks

this function will work for both nurbs curves and nurbs surfaces.

set the indexed vertex of the indexed point of the given nurbs curve or the indexed (index2)control point of the surfaces in either the U (index 1= 1)or V(index1 =0) direction

Example

VectorScript

See NurbsSurfaceEvalPt

Python


Version

Availability: from VectorWorks9.0