VS:NurbsSetKnot

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the specified knot in a NURBS curve or surface.

For NURBS curves, index1 corresponds to a segment of the curve, and index2 corresponds to the knot in the segment.

For NURBS surfaces, index1 corresponds to the u- or v-direction of the surface and index2 corresponds to the knot.

The index is zero based (0 to number of knots - 1).

PROCEDURE NurbsSetKnot(
objectHd :HANDLE;
index1 :LONGINT;
index2 :LONGINT;
knot :REAL);
def vs.NurbsSetKnot(objectHd, index1, index2, knot):
    return None

Parameters

objectHd HANDLE Handle to NURBS curve or surface.
index1 LONGINT Segment of curve to be queried (NURBS curve), or direction (NURBS surface).
index2 LONGINT Index of segment or direction knot.
knot REAL Knot value.

Remarks

this function will work for both nurbs curves and nurbs surfaces

Version

Availability: from VectorWorks9.0