VS:NurbsNumKnots

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the number of knots for the referenced NURBS curve or surface. If the object is a curve, then index indicates the segment of the curve to consider. If the object is a surface, then the index indicates the U direction (for index = 1) or the V direction (for index = 0).

FUNCTION NurbsNumKnots(
objectHd :HANDLE;
index :LONGINT) : LONGINT;
def vs.NurbsNumKnots(objectHd, index):
    return LONGINT

Parameters

objectHd HANDLE Handle to NURBS curve or surface.
index LONGINT Index of curve, or U/V choice for surface.

Remarks

/this function will work for both nurbs curves and nurbs surfaces.

returns the number of knots for the indexed piece of the given nurbs curve. or number of U knot vector (index=1) or V knot vector (index=0) of the given nurbs surface

Example

VectorScript

See NurbsSurfaceEvalPt

Python


Version

Availability: from VectorWorks9.0