VS:NurbsGetPt3D

From Vectorworks Developer
Revision as of 14:35, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the coordinates of a point in the referenced NURBS curve or surface.

The index is zero based (0 to number of points - 1).

PROCEDURE NurbsGetPt3D(
objectHd :HANDLE;
index1 :LONGINT;
index2 :LONGINT;
VAR pX,pY,pZ :REAL);
def vs.NurbsGetPt3D(objectHd, index1, index2):
    return p

Parameters

objectHd HANDLE Handle to NURBS curve or surface.
index1 LONGINT Index of point in NURBS curve, or u-coordinate of point location in NURBS surface.
index2 LONGINT V-coordinate of point location in NURBS surface.
p REAL Coordinates of the control point.

Remarks

this function will work for both nurbs curves and nurbs surfaces.

Gets the index2 vertex of the indexe1 piece of the given NURBS curve or the index1 U and index2 V control point of the surfaces.


For a nurbs curve, index1 is the piece number of the nurbs curve. Index2 is the vertex number within that piece.

NurbsCurveGetNumPieces will give you the number of pieces inside of the nurbs curve. (1-based)

NurbsGetNumPts will give you the number of points inside of a piece.

Version

Availability: from VectorWorks9.0

See Also

VS Functions:

VS:NurbsCurveEvalPt | VS:NurbsSurfaceEvalPt

VS Functions:

[[VS:NurbsCurveEvalPt]]

| [[VS:NurbsSurfaceEvalPt]]