VS:NurbsGetNumPts

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the number of points for segment of the referenced NURBS curve, or the number of points of the referenced NURBS surface in the u- or v-direction.

For NURBS curves, the index indicates which segment of the curve is to be queried. The index is zero based (0 to number of segments - 1).

For NURBS surfaces, specify an index of 1 to indicate u-direction, and an index of 0 to indicate v-direction when querying the surface object.

FUNCTION NurbsGetNumPts(
objectHd :HANDLE;
index :LONGINT) : LONGINT;
def vs.NurbsGetNumPts(objectHd, index):
    return LONGINT

Parameters

objectHd HANDLE Handle to NURBS curve or surface.
index LONGINT Index of curve segment (NURBS curve) or direction index (NURBS surface).

Return Value

The number of control points as a LONGINT value.

Remarks

this function will work for both nurbs curves and nurbs surfaces.

Version

Availability: from VectorWorks9.0