VS:NurbsDegree

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the degree of a segment in a NURBS curve or surface.

For NURBS curves, the index indicates which segment of the curve is to be queried. The index is zero based (0 to number of segments - 1).

For NURBS surfaces, specify an index of 1 to indicate u-direction, and an index of 0 to indicate v-direction when querying the surface object.

FUNCTION NurbsDegree(
objectHd :HANDLE;
index :INTEGER) : INTEGER;
def vs.NurbsDegree(objectHd, index):
    return INTEGER

Parameters

objectHd HANDLE Handle to NURBS curve or surface.
index INTEGER Index of curve segment (NURBS curve) or direction index (NURBS surface).

Return Value

The degree of the segment as an INTEGER value.

Version

Availability: from VectorWorks9.0