VS:NurbsCurveType

From Vectorworks Developer
Revision as of 14:35, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the curve type of a segment of the referenced NURBS curve.

The index is zero based (0 to number of segments - 1).

PROCEDURE NurbsCurveType(
objectHd :HANDLE;
index :LONGINT;
VAR isByFit :BOOLEAN);
def vs.NurbsCurveType(objectHd, index):
    return isByFit

Parameters

objectHd HANDLE Handle to NURBS curve.
index LONGINT Index of curve segment.
isByFit BOOLEAN Type of curve segment.

Return Value

Returns a BOOLEAN indicating whether the curve is created by fit point (TRUE) or by control point (FALSE).

Version

Availability: from VectorWorks9.0