VS:NurbsCurveGetNumPieces

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the number of pieces that compose the referenced NURBS curve.

FUNCTION NurbsCurveGetNumPieces(
objectHd :HANDLE) : INTEGER;
def vs.NurbsCurveGetNumPieces(objectHd):
    return INTEGER

Parameters

objectHd HANDLE Handle to NURBS curve.

Return Value

An INTEGER count of the pieces composing the curve.

Remarks

See example on VS:NurbsGetPt3D

Example

A representation of pieces (segments in the example) in a NURBS curve:

Version

Availability: from VectorWorks 9.0