VS:NurbsCurveGetNumPieces

From Vectorworks Developer
Revision as of 08:03, 3 February 2022 by CBM-c- (talk | contribs) (add illustration)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the number of pieces that compose the referenced NURBS curve.

FUNCTION NurbsCurveGetNumPieces(
objectHd :HANDLE) : INTEGER;
def vs.NurbsCurveGetNumPieces(objectHd):
    return INTEGER

Parameters

objectHd HANDLE Handle to NURBS curve.

Return Value

An INTEGER count of the pieces composing the curve.

Remarks

See example on VS:NurbsGetPt3D

Example

A representation of pieces (segments in the example) in a NURBS curve:

Version

Availability: from VectorWorks 9.0