VS:NurbsCurveGetNumPieces: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(add illustration)
 
Line 29: Line 29:
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<remark>See example on [[VS:NurbsGetPt3D]]</remark>
-----------------------------------------------------------------------------------------------------------
<sample>
A representation of pieces (segments in the example) in a NURBS curve:
[[File:NURBS_Pieces.png| 500px]]
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 36: Line 48:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from VectorWorks9.0
Availability: from VectorWorks 9.0


</version>
</version>

Latest revision as of 08:03, 3 February 2022

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the number of pieces that compose the referenced NURBS curve.

FUNCTION NurbsCurveGetNumPieces(
objectHd :HANDLE) : INTEGER;
def vs.NurbsCurveGetNumPieces(objectHd):
    return INTEGER

Parameters

objectHd HANDLE Handle to NURBS curve.

Return Value

An INTEGER count of the pieces composing the curve.

Remarks

See example on VS:NurbsGetPt3D

Example

A representation of pieces (segments in the example) in a NURBS curve:

Version

Availability: from VectorWorks 9.0