VS:NumCustomObjectChoices

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function NumCustomObjectChoices returns the number of choice strings for a specified popup menu or radio group parameter in a plug-in object.

The string passed into the parameter name argument should use the parameter constant syntax, not the actual parameter name. The string should have the prefix character 'P', and should have all spaces replaced with underscore characters. For example, a parameter Jamb Depth would have a constant declared as PJAMB_DEPTH and therefore the parameter name argument to this function should be the string 'PJAMB_DEPTH'.

FUNCTION NumCustomObjectChoices(
objectName :STRING;
parameterName :STRING) : INTEGER;
def vs.NumCustomObjectChoices(objectName, parameterName):
    return INTEGER

Parameters

objectName STRING Name of plugin object.
parameterName STRING String indicating which parameter

Remarks

Call from CustomObject scripts only. Return number of choice strings for a particular popup menu or radio group parameter.

Example

VectorScript

maxChoices := NumCustomObjectChoices(objName, 'PDINNER_MENU');

Python


Version

Availability: from VectorWorks8.0

See Also

VS Functions:

VS:GetCustomObjectChoice

VS Functions: [[VS:GetCustomObjectChoice]]