VS:NumChoices

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function NumChoices returns the number of values available in the specified VectorScript dialog choice item list.

FUNCTION NumChoices(
item :INTEGER) : INTEGER;
def vs.NumChoices(item):
    return INTEGER

Parameters

item INTEGER Item ID of dialog choice item control.

Remarks

Note: deprecated from VW 15+, use GetChoiceCount.

The number of values currently added to a combo box

[sd 8/19/98]

Example

VectorScript

numOptions:=NumChoices(8);

Python


Version

Availability: from VectorWorks 8.0. Deprecated from VW 15+.