VS:Num2StrF

From Vectorworks Developer
Revision as of 14:35, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function Num2StrF converts a specified REAL value into a string. The numeric value will be converted and displayed in the current unit settings of the drawing.

FUNCTION Num2StrF(
vDistance :REAL) : STRING;
def vs.Num2StrF(vDistance):
    return STRING

Parameters

vDistance REAL Numeric value.

Remarks

This appears not to work as advertised. The string value returned appears to be in inches no matter the unit settings of the document.

Example

oldnumValue:=23.45;
newStrValue:=Num2StrF(oldnumValue);
{would return 1'-11 1/2"}

Version

Availability: from All Versions