VS:NoAngleVar

From Vectorworks Developer
Revision as of 21:07, 7 October 2015 by Jaredm (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the angle designation method in VectorScript. When called, VectorScript will treat language symbols which can be interpreted as direction angles (e.g., N, S, NW, SE) as as angles, rather than as variables.

PROCEDURE NoAngleVar;
def vs.NoAngleVar():
    return None

Example

VectorScript

procedure test;
var
S : Real;

begin
NoAngleVar;
S := 30;
LineTo(3", #S);
{ The 'S' will be treated as the direction 'South'  }
{ and line will be drawn on 270 degree angle. }

end;
run(test);

Python

vs.NoAngleVar()

Version

Availability: from All Versions