VS:NoAngleVar: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
No edit summary
 
(2 intermediate revisions by 2 users not shown)
Line 39: Line 39:
==== Python ====
==== Python ====
<code lang="py">
<code lang="py">
 
vs.NoAngleVar()
</code>
</code>
</sample>
</sample>

Latest revision as of 21:07, 7 October 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the angle designation method in VectorScript. When called, VectorScript will treat language symbols which can be interpreted as direction angles (e.g., N, S, NW, SE) as as angles, rather than as variables.

PROCEDURE NoAngleVar;
def vs.NoAngleVar():
    return None

Example

VectorScript

procedure test;
var
S : Real;

begin
NoAngleVar;
S := 30;
LineTo(3", #S);
{ The 'S' will be treated as the direction 'South'  }
{ and line will be drawn on 270 degree angle. }

end;
run(test);

Python

vs.NoAngleVar()

Version

Availability: from All Versions