VS:NextDObj

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function NextDObj returns the next deselected object after the referenced object in a list. If the end of the list is reached, the function returns NIL.

FUNCTION NextDObj(
h :HANDLE) : HANDLE;
def vs.NextDObj(h):
    return HANDLE

Parameters

h HANDLE Handle to object.

Example

VectorScript

handleToObject:=FObject;
WHILE handleToObject <> NIL DO BEGIN
SetSelect(handleToObject);
handleToObject:=NextDObj(handleToObject);
END;
{ selects all deselected objects }

Python


Version

Availability: from All Versions

See Also

Relative calls:

Relative calls:
  • [[VS:NextObj]] | [[VS:PrevObj]]
  • [[VS:FObject]] | [[VS:LObject]]
  • [[VS:FSActLayer]] | [[VS:LSActLayer]]
  • [[VS:FSObject]] | [[VS:LActLayer]]
  • [[VS:NextDObj]] | [[VS:PrevDObj]]
  • [[VS:NextSObj]] | [[VS:PrevSObj]]