VS:NewField/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

レコードに新しいレコードフィールドを追加します。指定した名前のレコードが存在しなければ、新しいレコードを作成します。

PROCEDURE NewField(
recName :STRING;
fieldName :STRING;
fieldValue :DYNARRAY[] of CHAR;
fType :INTEGER;
fFlag :INTEGER);
def vs.NewField(recName, fieldName, fieldValue, fType, fFlag):
    return None

Parameters

recName STRING レコードの名前
fieldName STRING レコードフィールドの名前
fieldValue DYNARRAY[] of CHAR レコードフィールドの初期値
fType INTEGER レコードフィールドの形式
fFlag INTEGER レコードフィールドのフラグ

Example

NewField('Part Info','Serial No.','A-0000',4,0);

Version

利用可能バージョン: MiniCAD