VS:NameObject

From Vectorworks Developer
Revision as of 20:08, 30 September 2008 by Root (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure NameObject assigns an object name to the next object created.

PROCEDURE NameObject(
objName :STRING);
def vs.NameObject(objName):
    return None

Parameters

objName STRING Name to be assigned to object.

Example

VectorScript

NameObject('Part 5257');
Rect(0,2,2,0);

On Vectorworks 2009 the function have problems with groups (VS:BeginGroup and VS:EndGroup). In order to workaround the problem use this (VS:SetName call):

BeginGroup;
Rect(0,2,2,0);
EndGroup;
SetName(LNewObj, 'Part 5257');

Python


Version

Availability: from All Versions