VS:NameClass: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 9: Line 9:
If the specified class already exists, then it will become the active class of the document.
If the specified class already exists, then it will become the active class of the document.


Note: Class names cannot exceed 20 characters.
Note: Class names cannot exceed 63 characters.


</desc>
</desc>

Latest revision as of 16:27, 18 February 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a new class in a VectorWorks document, which then become the active class.

If the specified class already exists, then it will become the active class of the document.

Note: Class names cannot exceed 63 characters.

PROCEDURE NameClass(
className :STRING);
def vs.NameClass(className):
    return None

Parameters

className STRING Name of class.

Example

VectorScript

NameClass('Revisions');
Rect(4,4,6,6);

{Create a class 'Revisions' in the document}
{The rectangle is then assigned this class }

Python


Version

Availability: from All Versions