VS:MoveWallByOffset/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ARCHITECTでのみ利用可能です。すべての壁の連結を維持したまま、壁を指定した値で定義した線に垂直に動かします。壁の移動の幾何学的に拘束されているので、実際に壁が動いた値を返します。

PROCEDURE MoveWallByOffset(
theWall :HANDLE;
VAR offset :REAL);
def vs.MoveWallByOffset(theWall, offset):
    return offset

Parameters

theWall HANDLE 壁のハンドル
offset REAL 壁を動かす距離

Return Value

実際に壁が移動した値を返します。

Version

利用可能バージョン: VectorWorks10.0