VS:MoveObjs

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure MoveObjs moves object(s) a specified offset distance. The last two parameters, allLayers and allObjects, control which objects are offset by this procedure.

Table - Effect of MoveObjs Parameters
allLayers allObjects Effect
TRUE TRUE Move all objects on all layers
TRUE FALSE Move selected objects on all layers
FALSE TRUE Move all objects on active layer
FALSE FALSE Move selected objects on active layer
PROCEDURE MoveObjs(
move :REAL;
allLayers :BOOLEAN;
allObjects :BOOLEAN);
def vs.MoveObjs(move, allLayers, allObjects):
    return None

Parameters

move REAL X-Y object offset distance.
allLayers BOOLEAN Move objects on all layers option setting.
allObjects BOOLEAN Move all objects option setting.

Example

VectorScript

MoveObjs(3,0,FALSE,FALSE);
{ moves selected objects on active layer 3 units to the right }

Python


Version

Availability: from All Versions