VS:Move3D

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure Move3D moves the most recently created three-dimensional object a relative distance from it's original location. The object is moved relative to its center.

PROCEDURE Move3D(
xDistance :REAL;
yDistance :REAL;
zDistance :REAL);
def vs.Move3D(xDistance, yDistance, zDistance):
    return None

Parameters

xDistance REAL X offset distance.
yDistance REAL Y offset distance.
zDistance REAL Z offset ditance.

Example

VectorScript

BeginXtrd(0',2");
Rect(0",1",1",0");
EndXtrd;
Move3D(3",1",2");

Python


Version

Availability: from All Versions