VS:Move

From Vectorworks Developer
Revision as of 21:46, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the position of the graphics pen in the VectorWorks document by moving a specified distance from the current pen location.

Horizontal and vertical offsets from the initial location. The final position of the pen at a point whose coordinates are (x+moveDX, y+moveDY).

PROCEDURE Move(
move :REAL);
def vs.Move(move):
    return None

Parameters

move REAL X-Y offset distance.

Remarks

The difference between this and MoveTo is that this is relative, whereas MoveTo is absolute.

Example

VectorScript

Move(6,1);
{ moves the graphics pen 6 units to the right }
{ and 1 unit up from the current position.    }

Python


Version

Availability: from All Versions

See Also

VS Functions:

VS:MoveTo

VS Functions: [[VS:MoveTo]]