VS:Move: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
mNo edit summary
 
(One intermediate revision by one other user not shown)
Line 47: Line 47:
==== Python ====
==== Python ====
<code lang="py">
<code lang="py">
 
vs.Move(6, 1)
</code>
</code>
</sample>
</sample>

Latest revision as of 21:05, 7 October 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the position of the graphics pen in the VectorWorks document by moving a specified distance from the current pen location.

Horizontal and vertical offsets from the initial location. The final position of the pen at a point whose coordinates are (x+moveDX, y+moveDY).

PROCEDURE Move(
move :REAL);
def vs.Move(move):
    return None

Parameters

move REAL X-Y offset distance.

Remarks

The difference between this and MoveTo is that this is relative, whereas MoveTo is absolute.

Example

VectorScript

Move(6,1);
{ moves the graphics pen 6 units to the right }
{ and 1 unit up from the current position.    }

Python

vs.Move(6, 1)

Version

Availability: from All Versions

See Also

VS Functions:

VS:MoveTo

VS Functions: [[VS:MoveTo]]