VS:Moments3D

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the moments of inertia of a 3D object about the x, y, and z axes of a point at the center of gravity of the object.

FUNCTION Moments3D(
obj :HANDLE;
VAR lxx :REAL;
VAR lyy :REAL;
VAR lzz :REAL) : BOOLEAN;
def vs.Moments3D(obj):
    return (BOOLEAN, lxx, lyy, lzz)

Parameters

obj HANDLE The object for which to find the 3D moments.
lxx REAL The moment of inertia relative to the x-axis passing through the center of mass of object
lyy REAL The moment of inertia relative to the y-axis passing through the center of mass of object
lzz REAL The moment of inertia relative to the z-axis passing through the center of mass of object

Return Value

Returns true if the function succeeded.

Version

Availability: from VectorWorks 10.1