VS:Moments3D: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
(No difference)

Revision as of 14:34, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the moments of inertia of a 3D object about the x, y, and z axes of a point at the center of gravity of the object.

FUNCTION Moments3D(
object :HANDLE;
VAR lxx :REAL;
VAR lyy :REAL;
VAR lzz :REAL) : BOOLEAN;
def vs.Moments3D(object):
    return (BOOLEAN, lxx, lyy, lzz)

Parameters

object HANDLE The object for which to find the 3D moments.
lxx REAL The moment of inertia relative to the x-axis passing through the center of mass of object
lyy REAL The moment of inertia relative to the y-axis passing through the center of mass of object
lzz REAL The moment of inertia relative to the z-axis passing through the center of mass of object

Return Value

Returns true if the function succeeded.

Version

Availability: from VectorWorks10.1