VS:Moments3D: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(Shorten OBJECT, reserved word)
 
(One intermediate revision by one other user not shown)
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION Moments3D(object:HANDLE; VAR lxx:REAL; VAR lyy:REAL; VAR lzz:REAL) : BOOLEAN;
FUNCTION Moments3D(obj:HANDLE; VAR lxx:REAL; VAR lyy:REAL; VAR lzz:REAL) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.Moments3D(object):
def vs.Moments3D(obj):
     return (BOOLEAN, lxx, lyy, lzz)
     return (BOOLEAN, lxx, lyy, lzz)
</funcDef>
</funcDef>
Line 23: Line 23:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object for which to find the 3D moments.
The object for which to find the 3D moments.
Line 51: Line 51:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from VectorWorks10.1
Availability: from VectorWorks 10.1


</version>
</version>

Latest revision as of 20:04, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the moments of inertia of a 3D object about the x, y, and z axes of a point at the center of gravity of the object.

FUNCTION Moments3D(
obj :HANDLE;
VAR lxx :REAL;
VAR lyy :REAL;
VAR lzz :REAL) : BOOLEAN;
def vs.Moments3D(obj):
    return (BOOLEAN, lxx, lyy, lzz)

Parameters

obj HANDLE The object for which to find the 3D moments.
lxx REAL The moment of inertia relative to the x-axis passing through the center of mass of object
lyy REAL The moment of inertia relative to the y-axis passing through the center of mass of object
lzz REAL The moment of inertia relative to the z-axis passing through the center of mass of object

Return Value

Returns true if the function succeeded.

Version

Availability: from VectorWorks 10.1