VS:ModifySlab

From Vectorworks Developer
Revision as of 14:34, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Adds to or clips from a slab.

FUNCTION ModifySlab(
slab :HANDLE;
modifier :HANDLE;
isClipObject :BOOLEAN;
componentFlags :LONGINT) : BOOLEAN;
def vs.ModifySlab(slab, modifier, isClipObject, componentFlags):
    return BOOLEAN

Parameters

slab HANDLE The slab.
modifier HANDLE The adding or clipping object.
isClipObject BOOLEAN Whether the modifier is an add object or a clip object.
componentFlags LONGINT Bit flags that indicate which components will be affected by the modification.

Return Value

Whether or not the modification succeeds.

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:CreateSlab

VS Functions: [[VS:CreateSlab]]