VS:MirrorN

From Vectorworks Developer
Revision as of 20:40, 15 September 2022 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Reflect an object across an axis.


For a 2D reflection, the axis is a line containing arbitrary point p and extending along vector v.

The difference with Mirror, when preserveMatrix is set to true, is that this function preserves the matrix of the objects that have one, which leads to better visual results.

FUNCTION MirrorN(
h :HANDLE;
dup :BOOLEAN;
p1 :REAL;
p2 :REAL;
preserveMatrix :BOOLEAN) : HANDLE;
def vs.MirrorN(h, dup, p1, p2, preserveMatrix):
    return HANDLE

Parameters

h HANDLE The object to reflect
dup BOOLEAN If false, transform the original object to the new position. If true, create a new object
p1 REAL An arbitrary point on the mirror axis
p2 REAL A second arbitrary point on the mirror axis
preserveMatrix BOOLEAN When this parameter is set to false, then this function works exactly the same as Mirror. Otherwise, objects that have matrices, such as Symbols and PIOs, get their matrices updated correctly with the mirror matrix, leading to better visual results.

Return Value

The reflected object (this will be the same as the input object if dup is false).

Version

Availability: from Vectorworks 2023