VS:Mirror: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
Line 13: Line 13:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION Mirror(h:HANDLE; dup:BOOLEAN; p1:REAL; p2:REAL) : HANDLE;
FUNCTION Mirror(h:HANDLE; dup:BOOLEAN; p1:POINT; p2:POINT) : HANDLE;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">

Revision as of 19:19, 17 July 2019

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Reflect an object across an axis.


For a 2D reflection, the axis is a line containing arbitrary point p and extending along vector v.

FUNCTION Mirror(
h :HANDLE;
dup :BOOLEAN;
p1 :POINT;
p2 :POINT) : HANDLE;
def vs.Mirror(h, dup, p1, p2):
    return HANDLE

Parameters

h HANDLE The object to reflect
dup BOOLEAN If false, transform the original object to the new position. If true, create a new object
p1 REAL An arbitrary point on the mirror axis
p2 REAL A second arbitrary point on the mirror axis

Return Value

The reflected object (this will be the same as the input object if dup is false).

Version

Availability: from Vectorworks 2017