VS:Mirror: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Add info about failures)
(Add info about failures)
Line 52: Line 52:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
([[User:Orso.b.schmid|Orso]], 2019.11.09) This doesn't support Groups and is unpredictable on 3D objects.
([[User:Orso.b.schmid|Orso]], 2019.11.09) This doesn't support Groups and is unpredictable on 3D objects
 
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 10:18, 9 November 2019

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Reflect an object across an axis.


For a 2D reflection, the axis is a line containing arbitrary point p and extending along vector v.

FUNCTION Mirror(
h :HANDLE;
dup :BOOLEAN;
p1 :POINT;
p2 :POINT) : HANDLE;
def vs.Mirror(h, dup, p1, p2):
    return HANDLE

Parameters

h HANDLE The object to reflect
dup BOOLEAN If false, transform the original object to the new position. If true, create a new object
p1 POINT An arbitrary point on the mirror axis
p2 POINT A second arbitrary point on the mirror axis

Return Value

The reflected object (this will be the same as the input object if dup is false).

Remarks

(Orso, 2019.11.09) This doesn't support Groups and is unpredictable on 3D objects

Version

Availability: from Vectorworks 2017