VS:Mirror: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
(fix mistake)
 
(4 intermediate revisions by 2 users not shown)
Line 36: Line 36:
<line>
<line>
p1
p1
REAL
POINT
An arbitrary point on the mirror axis
An arbitrary point on the mirror axis
</line>
</line>
<line>
<line>
p2
p2
REAL
POINT
A second arbitrary point on the mirror axis
A second arbitrary point on the mirror axis
</line>
</line>
Line 52: Line 52:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
([[User:CBM-c-|_c_]], 2019.11.09) This doesn't support Groups and is unpredictable on 3D objects
 
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 05:28, 15 January 2021

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Reflect an object across an axis.


For a 2D reflection, the axis is a line containing arbitrary point p and extending along vector v.

FUNCTION Mirror(
h :HANDLE;
dup :BOOLEAN;
p1 :POINT;
p2 :POINT) : HANDLE;
def vs.Mirror(h, dup, p1, p2):
    return HANDLE

Parameters

h HANDLE The object to reflect
dup BOOLEAN If false, transform the original object to the new position. If true, create a new object
p1 POINT An arbitrary point on the mirror axis
p2 POINT A second arbitrary point on the mirror axis

Return Value

The reflected object (this will be the same as the input object if dup is false).

Remarks

(_c_, 2019.11.09) This doesn't support Groups and is unpredictable on 3D objects

Version

Availability: from Vectorworks 2017