VS:Min

From Vectorworks Developer
Revision as of 17:27, 13 August 2008 by Root (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the minimum of the two numbers.

FUNCTION Min(
val1 :REAL;
val2 :REAL) :REAL;
def vs.Min(val1, val2):
    return REAL

Parameters

val1 REAL
val2 REAL

Example

PROCEDURE Example;
VAR
   a, b, c : REAL;
BEGIN
    a := RealDialog('Enter one real number:', '0');
    b := RealDialog('Enter another real number:', '0');
    c := Min(a, b);
    AlrtDialog(Concat('Min(', a, ', ', b, ')=', c));
END;
RUN(Example);

Version

Availability: from All Versions

This is drop-in function.