VS:Min: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
(No difference)

Revision as of 14:34, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the minimum of the two numbers.

FUNCTION Min(
val1 :REAL;
val2 :REAL) :REAL;
def vs.Min(val1, val2):
    return REAL

Parameters

val1 REAL
val2 REAL

Example

PROCEDURE Example;
VAR
   a, b, c : REAL;
BEGIN
    a := RealDialog('Enter one real number:', '0');
    b := RealDialog('Enter another real number:', '0');
    c := Min(a, b);
    AlrtDialog(Concat('Min(', a, ', ', b, ')=', c));
END;
RUN(Example);

Version

Availability: from All Versions

This is drop-in function.