VS:MakePolygon

From Vectorworks Developer
Revision as of 12:54, 16 September 2015 by Root (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

MakePolygon creates a 2D Polygon using inSourceObject. Does not delete inSourceObject.

FUNCTION MakePolygon(
inSourceObject :HANDLE) : HANDLE;
def vs.MakePolygon(inSourceObject):
    return HANDLE

Parameters

inSourceObject HANDLE inSource object should be a 2D object that can be polygonalized.

Return Value

A polygonalized copy of inSourceObject

Remarks

This routine creates its returned object not as the last object in the active layer, but immediately after inSourceObject in the stacking order, so if you delete inSourceObject, you will have "replaced" it.


See also: <a href=http://www.vectorworks.net/support/custom/vscript/reference/asp/main.asp?name=ConvertToPolygon>ConvertToPolygon</a>.

Example

VectorScript

PROCEDURE Example;
VAR
h :HANDLE;
BEGIN
CallTool(-204);
h := FSActLayer;
h := MakePolygon(h);
END;
RUN(Example);

Python


Version

Availability: from VectorWorks10.1