VS:LinkText/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ハンドルで指定した文字図形にレコードとレコードフィールドを連結させます。この機能は「文字をレコードに連結」メニューに相当し、シンボル内の文字の制御に使います。

PROCEDURE LinkText(
h :HANDLE;
rec :STRING;
fld :STRING);
def vs.LinkText(h, rec, fld):
    return None

Parameters

h HANDLE 文字のハンドル
rec STRING レコードの名前
fld STRING レコードフィールドの名前

Example

BeginSym('Symbol #2');
  Oval(-3/4",1/2",3/4",-1/2");
  TextFont(3);
  TextSize(12.00037);
  TextJust(1);
  TextOrigin(0.8611111",0.5138889");
  BeginText;
   'Field 9 String'
  EndText;
  LinkText(LNewObj,'Sample Format','Field 1');
EndSym;
Record(LNewObj,'Sample Format');

Version

利用可能バージョン: MiniCAD

See Also

利用可能バージョン:

VS:BeginSym | VS:EndSym

利用可能バージョン:

[[VS:BeginSym]]

| [[VS:EndSym]]