VS:LinkText: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
(No difference)

Revision as of 14:34, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a linked text field in a newly created symbol. The specified text is linked to a record field, whose value is displayed by the text object.

LinkText must be called during symbol creation; the record to be associated with the linked text string must also exist at the time the link is created.

PROCEDURE LinkText(
h :HANDLE;
rec :STRING;
fld :STRING);
def vs.LinkText(h, rec, fld):
    return None

Parameters

h HANDLE Handle to text object that will be linked to record.
rec STRING Name of record that will be linked to text string.
fld STRING Name of field that will be linked to text string.

Example

VectorScript

BeginSym('Symbol #2');
Oval(-3/4",1/2",3/4",-1/2");
TextFont(3);
TextSize(12.00037);
TextJust(1);
TextOrigin(0.8611111",0.5138889");
BeginText;
'Field 9 String'
EndText;
LinkText(LNewObj,'Sample Format','Field 1');
EndSym;
Record(LNewObj,'Sample Format');

Python


Version

Availability: from All Versions

See Also

VS Functions:

VS:BeginSym | VS:EndSym

VS Functions:

[[VS:BeginSym]]

| [[VS:EndSym]]