VS:LineTo

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure LineTo creates a line object in the document. LineTo draws from the current graphics pen position to the specified coordinate location. The line object is drawn with the current default attributes unless otherwise specified in the VectorScript routine.

PROCEDURE LineTo(
pX,pY :REAL);
def vs.LineTo(p):
    return None

Parameters

p REAL Line endpoint.

Remarks

(Joel Sciamma, 2006.08.14): After the line is drawn, the graphics pen is set to the end of the line ready to draw another object. Use MoveTo to reset the graphics pen position.

Example

VectorScript

LineTo(3,4);
{draws a line from the current pen position to (3, 4)}

Python


Version

Availability: from All Versions

See Also

VS Functions: VS:Absolute | VS:Relative

VS Functions: [[VS:Absolute]] | [[VS:Relative]]