VS:LineEllipseIntersect/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

線分と楕円の交点を返します。

PROCEDURE LineEllipseIntersect(
a1 :POINT;
a2 :POINT;
upperRight :POINT;
lowerLeft :POINT;
VAR int1 :POINT;
VAR legal1 :BOOLEAN;
VAR int2 :POINT;
VAR legal2 :BOOLEAN);
def vs.LineEllipseIntersect(a1, a2, upperRight, lowerLeft):
    return (int1, legal1, int2, legal2)

Parameters

a1 POINT 線分の始点座標
a2 POINT 線分の終点座標
upperRight POINT 円弧の右上の座標
lowerLeft POINT 円弧の左下の座標
int1 POINT 交点1の座標
legal1 BOOLEAN 交点の有無
int2 POINT 交点2の座標
legal2 BOOLEAN 交点の有無

Version

利用可能バージョン: VectorWorks10.0