VS:LineEllipseIntersect/ja

From Vectorworks Developer
Revision as of 12:30, 14 January 2016 by Kimura (talk | contribs) (1 revision: Japanese Reference for 2016)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

線分と楕円の交点を返します。

PROCEDURE LineEllipseIntersect(
a1 :REAL;
a2 :REAL;
upperRight :REAL;
lowerLeft :REAL;
VAR int1 :REAL;
VAR legal1 :BOOLEAN;
VAR int2 :REAL;
VAR legal2 :BOOLEAN);
def vs.LineEllipseIntersect(a1, a2, upperRight, lowerLeft):
    return (int1, legal1, int2, legal2)

Parameters

a1 REAL 線分の始点座標
a2 REAL 線分の終点座標
upperRight REAL 円弧の右上の座標
lowerLeft REAL 円弧の左下の座標
int1 REAL 交点1の座標
legal1 BOOLEAN 交点の有無
int2 REAL 交点2の座標
legal2 BOOLEAN 交点の有無

Version

利用可能バージョン: VectorWorks10.0