VS:Line

From Vectorworks Developer
Revision as of 16:04, 11 July 2016 by Patrick (talk | contribs) (Undo the last edit - Sry wrong page)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure Line creates a line object in VectorWorks. The line is drawn from the current pen position(x,y) to the specified point. The point may also be thought of as the location (x+dX,y+dY), where dX and dY are x and y offsets, respectively.

The line object is drawn with the current default attributes unless otherwise specified.

PROCEDURE Line(
line :REAL);
def vs.Line(line):
    return None

Parameters

line REAL Offset values for line.

Example

VectorScript

Line(2,2);
{ draws a line from the current pen location to a point }
{ 2 horizontal and 2 vertical units away.               }

Python


Version

Availability: from All Versions