VS:LengthN

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the length of an object. If more than one object matches the search criteria, the function will return the sum of all the matching object lengths.

FUNCTION LengthN(
c :CRITERIA) : REAL;
def vs.LengthN(c):
    return REAL

Parameters

c CRITERIA Search criteria.

Example

LengthValue:=LengthN(C='CrossMembers');
{returns the length of all objects in class 'CrossMembers'}

Version

Availability: from Vectorworks 2012