VS:Len

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function Len returns the length of the specified string value.

FUNCTION Len(
v :DYNARRAY[] of CHAR) : INTEGER;
def vs.Len(v):
    return INTEGER

Parameters

v DYNARRAY[] of CHAR Source string.

Remarks

Vectorworks 2018: This function will behave differently when used during dialog creation.

When used between VS:CreateLayout, VS:CreateResizableLayout and VS:RunLayoutDialog and VS:RunLayoutDialogN it will return the length of a string in bytes count, mimicking dialog units.
This means that the number might not be what you expect during the creation of the layout. In this case where this is a problem, you can use it outside the creation and move the value via a variable.
This was needed to solve alignment issues with Japanese and Unicode in Vectorworks 2018.

Version

Availability: from All Versions