VS:LNewObj

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns a handle to the last object created by a VectorScript function call during the current script execution.

FUNCTION LNewObj : HANDLE;
def vs.LNewObj():
    return HANDLE

Return Value

Returns a HANDLE to the most recently created object, otherwise returns NIL.

Remarks

[As of 8.0.0b10]

If the object has been deleted since it was created, this function returns NIL. It is recommended that you call LNewObj immediately after the function or procedure which created the object to avoid problems.

Version

Availability: from All Versions