VS:LDevice SetParamStr

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set string parameter of a Lighting Device or attached Accessory by Worksheet Name. Use cell index 0 to operate on the first cell. Use cell index -1 to set value for all the cells.

Use accessory index -2 to ignore accessory values. Use accessory index 0 to operate on the first accessory of the specified cell. Use accessory index -1 to set value for all the accessories on the specified cell.

PROCEDURE LDevice_SetParamStr(
handle :HANDLE;
cellIndex :LONGINT;
accessoryIndex :LONGINT;
universalName :STRING;
newValue :STRING);
def vs.LDevice_SetParamStr(handle, cellIndex, accessoryIndex, universalName, newValue):
    return None

Parameters

handle HANDLE
cellIndex LONGINT
accessoryIndex LONGINT
universalName STRING
newValue STRING

Version

Availability: from Vectorworks 2021