VS:LDevice SetParamLong

From Vectorworks Developer
Revision as of 15:48, 16 September 2020 by Unknown user
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set iong integer parameter of a Lighting Device or attached Accessory by Worksheet Name. Use cell index 0 to operate on the first cell. Use accessory index -1 to access the ligting device parameters.

PROCEDURE LDevice_SetParamLong(
handle :HANDLE;
cellIndex :LONGINT;
accessoryIndex :LONGINT;
universalName :STRING;
newValue :LONGINT);
def vs.LDevice_SetParamLong(handle, cellIndex, accessoryIndex, universalName, newValue):
    return None

Parameters

handle HANDLE
cellIndex LONGINT
accessoryIndex LONGINT
universalName STRING
newValue LONGINT

Version

Availability: from Vectorworks 2021