VS:LDevice SetParamBool

From Vectorworks Developer
Revision as of 15:48, 16 September 2020 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set boolean parameter of a Lighting Device or attached Accessory by Worksheet Name. Use cell index 0 to operate on the first cell. Use accessory index -1 to access the ligting device parameters.

PROCEDURE LDevice_SetParamBool(
handle :HANDLE;
cellIndex :LONGINT;
accessoryIndex :LONGINT;
universalName :STRING;
newValue :BOOLEAN);
def vs.LDevice_SetParamBool(handle, cellIndex, accessoryIndex, universalName, newValue):
    return None

Parameters

handle HANDLE
cellIndex LONGINT
accessoryIndex LONGINT
universalName STRING
newValue BOOLEAN

Version

Availability: from Vectorworks 2021