VS:LDevice GetParamStr

From Vectorworks Developer
Revision as of 15:04, 4 March 2021 by YAleksiev (talk | contribs)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get string parameter of a Lighting Device or attached Accessory by Worksheet Name. Use cell index 0 to operate on the first cell. Use cell index -1 to set value for all the cells. Cell index -1 is not supported for Get.

Use accessory index -2 to ignore accessory values. Use accessory index 0 to operate on the first accessory of the specified cell. Accessory index -1 is not supported for Get.

FUNCTION LDevice_GetParamStr(
handle :HANDLE;
cellIndex :LONGINT;
accessoryIndex :LONGINT;
universalName :STRING) : STRING;
def vs.LDevice_GetParamStr(handle, cellIndex, accessoryIndex, universalName):
    return STRING

Parameters

handle HANDLE
cellIndex LONGINT
accessoryIndex LONGINT
universalName STRING

Version

Availability: from Vectorworks 2021