VS:LDevice GetParamStr

From Vectorworks Developer
Revision as of 15:48, 16 September 2020 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get string parameter of a Lighting Device or attached Accessory by Worksheet Name. Use cell index 0 to operate on the first cell. Use accessory index -1 to access the ligting device parameters.

FUNCTION LDevice_GetParamStr(
handle :HANDLE;
cellIndex :LONGINT;
accessoryIndex :LONGINT;
universalName :STRING) : STRING;
def vs.LDevice_GetParamStr(handle, cellIndex, accessoryIndex, universalName):
    return STRING

Parameters

handle HANDLE
cellIndex LONGINT
accessoryIndex LONGINT
universalName STRING

Version

Availability: from Vectorworks 2021