VS:LDevice GetAccPos3D

From Vectorworks Developer
Revision as of 15:48, 16 September 2020 by Unknown user
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the 3D position and rotation of the specified accessory.

PROCEDURE LDevice_GetAccPos3D(
handle :HANDLE;
cellIndex :LONGINT;
accessoryIndex :LONGINT;
VAR outRotation3D :REAL;
VAR outPosition3D :REAL);
def vs.LDevice_GetAccPos3D(handle, cellIndex, accessoryIndex):
    return (outRotation3D, outPosition3D)

Parameters

handle HANDLE
cellIndex LONGINT
accessoryIndex LONGINT
outRotation3D REAL
outPosition3D REAL

Version

Availability: from Vectorworks 2021